Jump to content

Site Loading Issues


PheagleAdler
 Share

Recommended Posts

I seem to have this issue on-and-off, most of the time when I've had Google Chrome up for a while. The site loads fine when I first start up the browser, but over time, it crashes as soon as the site is fully loaded and I have to restart the browser to get it to work.

It's rather frustrating, and right now I'm using Firefox to type out this message, but my preferred and primary browser is Chrome so I'm hoping there's a way to fix this issue.

Could it be something to do with my extensions? Does the site use too much memory? I seem to have a similar problem viewing very large images in Chrome too...

Link to comment
Share on other sites

I have none of these issues in Safari for Mac.

However, the site is constantly crashing Safari tabs on my iPad mini 2, apparently from memory overload.
I believe it started with the site updates Care installed but i don't clearly remember.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...